Algorítmo do Amor



A noite do dia 12 de junho é dos namorados. O resto do ano, bem, é pra ser também. Seja você nerd, otaku, engenheiro de software ou o máximo da noobice você também merece amar e ser amado. O amor verdadeiro jamais será plenamente entendido, porém creio que tenha uma fórmula para saber se o que você sente é verdadeiro e existe uma reciprocidade. Para isso é necessário o seguinte logaritmo que desenvolvi a qual batizo-o de o Algorítmo do Amor:

Inicio
  |   Inteiro: amor, respeito, carinho, beleza;
  |   Char:  companheirismo;
  |   String: casamento, felicidade, amor_verdadeiro, saudades;
  |   respeito = 5
  |   amor = 5
  |   Enquanto respeito <> 0 Faça
  |     |    Escreva "Você acha ela bonita?";
  |     |    Leia beleza;
  |     |    Se beleza  >= 5 Então
  |     |     |  amor = amor + 5
  |     |    Senão
  |     |     |   amor = amor - 2
  |     |     |   respeito = respeito - 1
  |     |    FimSe
  |     |    Escreva "Existe companherismo na relação? (s/n)";
  |     |    Leia companherismo;
  |     |    Se  companherismo <> 's' Então
  |     |    |  amor = 0
  |     |    Senão
  |     |    |   amor = amor + 20
  |     |    |   respeito = respeito - 1
  |     |   FimSe
  |     |   Escreva "Qual nota de carinho você daria para ele(a)?";
  |     |   Leia carinho;
  |     |   Se carinho for => 8 Então
  |     |    | amor = amor + 20
  |     |   Senão
  |     |    | amor = amor - 10
  |     |    | Escreva "Beijos e Abraços gostosos";
  |     |   FimSe
  |   FimEnquanto
  |   Se amor >= 50 .E. respeito <> 0 Então
  |   |  amor_verdadeiro = "Infinito";
  |   |  saudades = "Enorme";
  |   |  casamento = "Duradouro";
  |   |  felicidade = "Certa";
  |   |  Escreva "Vocês se amam e Deus escreveu nas estrelas essa linda história de amor";
  |   Senão
  |   |  Escreva "Encontre outra pessoa e mude suas atitudes nos seus próximos relacionamentos";
  |   | 
  |   FimSe
Fim
    

   Pronto! Taí o que acho um algoritmo que diz tudo sobre o amor. Ufa, deu trabalho e eu sei que muitos vão discordar, hehe. Seja como for é uma lógica muito boa e quem seguí-la se dará muito bem. E se você não sabe ler Portugês Estruturado, bem, quem disse que conhecer as nuances e segredos do amor era fácil? Isso porque não descrevi como funciona a mente confusa das mulheres... Daí sim você ia se embananar...

Feliz dia dos namorados para todos, e para a minha Marcela:

Te amar nunca foi difícil, bastou te conhecer!

Te amo, amor da minha vida =*


Tomem Rumo Guris(a) Enamorados!!
 

1 comentário

Anônimo em 8 de junho de 2013 13:24

mtooo bacana esse algoritmo em